Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
5G routers, antennae and testing
#81
Mitsuha, not sure it's 5g enabled but it wasn't even a 4g mast 2 months ago so I assume when they upgraded it they would have future-proofed it. Their 5g map has all that area included but I think that map is guess work based on prior 4g connections & possibly the 700mhz 5g frequency they plan on using.

It is connected to the furthest away mast, that's in the opposite direction! I can't change the direction of the antenna until the installation engineer comes back.

Without the lteinspecteur I can't test & get figures for the respective masts. I'm currently only getting a reading for band 20 from the cpe router. It is aggregating though but I don't know what.

I might bring it up to my parents house in Cork city to see if I get 5g speeds from it.

Readings


Attached Files Image(s)
   
Reply
#82
Going by this post, Emilia used an App called Huawei Manager, which has band locking options. I'm not sure where it was downloaded from as it does not appear to be in the Google Play store, unless the App has a different name.

Based on the 5 bar signal strength, I don't think there is any data flowing over 5G. I would expect a few hundred Mbps with how few are using the network.

Just to rule out traffic shaping, try a speed test on the following website, choosing the Dublin "OneProvider" server in the server selection:
https://www.nperf.com/en/

On the other hand, at least you are getting an improvement over the B525. Cool If you decide to keep it, you may need to do a mod for the antenna to work as the TS9 antenna ports don't appear to work properly based both on Emilia's feedback and what I've come across elsewhere. Basically the mod involves running connections directly to the mainboard's antenna ports in place of the internal antennae.
Reply
#83
Thanks Sean. I couldn't find that app but found the apk. I can't aggregate bands but it allowed me to test individual bands.

I did your nperf test before I got the apk, when router was showing 5 bars of 4g & 5g. Speed was poor.

Using the apk I selected band 3 & ran the test. big difference.

Why is the carrier aggregation slower than the single band though?

the router is definitely better than the b525. 

on the antenna ports I thought it was working with the ts9 connectors I bought but maybe I'll check again 2moro, dont want to disturb the bats at this time of night!! ?

btw I did change the apn between tests but I dont think that was the difference as on other tests on testmy it didnt change.


Attached Files Image(s)
       
Reply
#84
That router can only aggregate certain band combinations on Three, so it's likely when you picked band 3 on its own, it was picking up and aggregating both band 3 carriers (EARFCNs 1275 and 1700). You can try ticking both bands 1 and 3 (leaving the rest unticked) to see what speed it gets aggregating these two.

It's quite likely the slower carrier aggregation was with it trying to aggregate the congested band 20 with the other bands. In your first screenshot above, those signal readings were terrible, i.e. -17dB RSRQ and -6dB are both about the edge of a usable connection, so if that was band 20 (most likely), it was probably causing the overall connection to slow with data packets being delayed over that congested problem band.
Reply
#85
Based on above I'm not sure I downloaded the correct apk as there aren't any boxes to tick. You can only select 1 band & there wasn't even a band 20 available to select. I'll search for the other apk 2moro.

I wonder am I better off with a mikrotik Lhg lte though & try & concentrate on the band 3 mast 3km away as I know it's not heavily congested. I think the mast is about 75m high while my house is about 35m with a rolling hill in the way, ie no direct line of sight.

When the weather clears I might take the cpe pro for a tour of the garden. Thanks
Reply
#86
Eventually found an English version of huawei manager (hmanager 5.0) which allowed me to aggregate 3 bands. You must select 4g & then select the bands you want(see pic).

You must also put in your router password & then restart your router. 

I think because my readings are so poor it's not of much benefit to me but to anyone with better reception this apk may help them. Maybe tonight at peak times it will help me.


Attached Files Image(s)
           
Reply
#87
Moved to another window aggregating a 15mhz & 20mhz band & got the following:


Attached Files Image(s)
       
Reply
#88
That's a big improvement Cool

As the SINR is negative, you should be able to improve that further by aiming the outdoor antenna in the direction of that window. The SINR may also be poor due to the low emissivity coating on modern glass windows. If the window is made of multiple glass panes (e.g. one side opens), you can try placing your router directly in-between the two panes to see if the SINR improves.

it also looks like your mast has very low, if any traffic shaping, which is also great. There are not many masts that get over 40Mbps on TestMy without using a specially configured VPN. For example, the one I'm connected has severe traffic shaping lately as TestMy has been averaging 6Mbps with the London server regardless of the time of day, yet can hit 100Mbps at times over a VPN.
Reply
#89
It looks like an identical issue that I had, if you try selecting band 3 + 20 on their own, and uncheck band 1 , see if the 5G symbol is showing then. If I unchecked band 1 it would no longer connect in 5G network mode. I wonder is that the same for everyone. But it was definitely not establishing a data connection over 5G on the router because the speeds were not reflective of 5G whatsoever. When we translate what it said in the Hmanager from chinese to english, it was saying 5G network mode - not activated.

I'm curious if the external antennas work for you, I'd try plugging them in and watching the readings if they change or not. It made no difference what so ever if I went into the router settings page and selected "internal" or "external" under antenna settings. Which looked like the antenna functionality is just not there. Maybe it only affected my device but I saw others complaining of the same thing on google.
Reply
#90
Will try the sinr trick as it very up & down & very sensitive. I had to change the extension lead & the mast number changed by 1 & my speed halved.

Does that mean its possibly picking up two band 3 masts & the band 1 mast? might explain the speed. I checked both mast numbers(810754, 810753) & they are both band 3.

Speeds at peak time tonight will be interesting but to hit over 80 at least means the router wasn't a waste of money.

Thanks for the advice. It makes a difference!

I'm afraid to go near the settings at the moment but might try the antenna again 2moro but I reckon now that the antenna wasnt working as I said it was picking up a mast in the opposite direction. The router was pointing that way!! Will double check 2moro.

As for 5g it's not showing anything with band 1 & 3 selected. will check 2moro if turning off band 1 brings back the 5g bars.

In my hmanager I don't have a 5g option to select.
Reply
#91
I had to have band 1 selected for it to get 5G signal bars at all .If I uncheck band 1 - I would no longer get 5G signal bars.  Like your image earlier on the router home page, the 5G signal bars are the same as the 4G signal bars, it was like that for me too. It looks like they're pairing the 5G with band 1 at least from the testing I managed to do. But no matter what it was unable to establish an actual data connection over 5G.

And yeah unfortunately, it looks like the external antenna ports aren't functional on the h112-372 for whatever reason. Though Seán linked a Video  earlier on a guy that connects external antennas directly to the routerboard using female sma-ipx connectors. If you're keeping the router and don't mind voiding the warranty then you could probably do this mod, at least from what I can tell it makes the external antennas functional this way. I just ordered those IPX connectors myself but i'll probably just refund the router anyway since I've lost my 4G signal as it is nevermind 5G Big Grin
Reply
#92
I watched that video again & he only fits one new ipx connector. Does he actually fit two but we dont see it in the video? you also don't see him put the cover back on with the new connection.

I'd like to know if 5g is possible before going at the router so I may call to my buddy who is only a few hundred meters from that upgraded mast. If I cant get 5g there then I can forget getting it 3kms away.

ps I'll wear a mask & socially distance!!
Reply
#93
There are 4 IPX connectors inside, but I think it's just the two going to the longer internal antennae that are used for the antennae adapters. I saw another video where the leads were fed through a ventilation opening on the base as both wires and the IPX connectors are thin enough to pass through. The IPX to SMA adapter leads need to be long enough to reach as the IPX connectors are near the TS9 connectors inside.

As for testing out and about (due to the Covid lockdown), I suggest getting an in-car DC adapter such as the following:
https://www.ebay.ie/itm/152026413295

This way you can power it in your car and drive to where you have clear line of sight of the mast. Smile
Reply
#94
Gees I think I have one of those DC adapters lying around somewhere.

I think I'll give the ipx connectors a go, as with my readings I need the external antenna.
Reply
#95
Tested that mast from my car. 5 bars of 5g but no 5g connection. Tried a few different apns but no difference. Would love to try a 5g phone to see if it would connect.

useful exercise though as found out based on speed testing 4g+ that I really should concentrate on the mast that's further away from me which I got 90mbps from my garage this morning.

ipx connectors coming Tuesday.
Reply
#96
Thanks for checking - Between this, the other responses here and further replies on Boards, Three is either preventing 5G routers or at least prepay phone SIMs in a router from making a data connection in 5G mode.  It's also possible that Three is limiting access to a specific list of devices like what I think Eir did at the start.  
 
Hopefully all goes well performing the mod for the IPX connectors.
Reply
#97
This explains what we all thought.

https://community.three.ie/t5/Suggestion...d-p/767239


Attached Files Image(s)
   
Reply
#98
From talking to one of Three's business reps today about wireless leased lines... I asked about 5G and he said "we're told 5G might be coming next month" so maybe we'll have some more options in November for 5G and trying it out . I have a narrow band 3400-3800 Mhz antenna that I haven't been able to test yet due to h112-372 not allowing external antenna connections and also Three blocking 5G data connections on the routers. I came across that post as well when looking for other people with the same issue as me. Definitely looks like its the case.

I might just buy a 5G capable phone now since i'm due an upgrade anyway still using an old Samsung S7, and it would mean I could do some extensive testing on three's 5G speeds on the Arranmore cell even if I have to drive nearer.  If they would just restore the damn service to how it used to be I'd be a lot more willing about it but as of right now I don't even get band 1 anymore (at least for a primary/single band mode , it wont show up but it does in CA mode) . So if 2100 Mhz 4G can't properly reach my external antennas (LPDA-92's) then what chance has 3500 Mhz + 5G got, even with beamforming and massive mimo, I dont think it'll work with the serving cell in its current state.


Infact as of right now three.ie website is down for maintenance , maybe we get lucky and they launch it tmoro Tongue doubt it though

[Image: OEfkHES.png]
Reply
#99
No 5g broadband plans yet but coming soon. I asked about my router as it was on a bill pay sim but same reply as above.

I enquired would an Xiaomi 5g phone be ok on the 3 network & this was the reply:

"If it's not purchased from us then I can't guarantee it will work. That's not to say that it won't, it may very well work perfectly. Best thing to do would be to test it out beforehand to make sure ?"

An Irish Examiner article from the end of September announcing Three 5g mentions 5g will only be available on some Samsung & Huawei handsets to start with.

I suppose we should just be patient!!
Reply
I found a thread on Reddit from somebody with a OnePlus 8 who couldn't connect to Three's 5G network with their device. The Three Customer Care representative told them that, as the device was not purchased directly from them, that they could not help. I'd assume this, along with all the other sources about using third-party 5G devices, verifies that Three still need to approve of other third-party 5G devices before they can connect to their network. Hopefully if they do launch their 5G broadband plans next month we will see our 5G routers being able to establish a connection.

A Redditor replied saying that Three 5G connectivity support will come in the form of a software update, so I wonder are Three actually blocking by IMEI or do they need to send out a new configuration profile that allows devices to connect to their 5G networks?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)