Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
5G routers, antennae and testing
#41
Just one thing that came to mind - Is there a centre pin on those SMA connectors on the SMA to TS9 leads?: (Correction update: The SMA end of the SMA to TS9 lead should be a SMA female plug without the centre pin)

   

If those adapters are missing that centre pin on the SMA plugs, then they will not work as they are for Wi-Fi (which has the centre pins on the router's Wi-Fi antenna sockets).

If you are able to get the router working in 5G (to make sure the 5G part works), the following video shows how to dismantle and mod the router to attach external antenna leads directly to the motherboard in place of the internal antennae.  According to the video, this gives better signal strength than using the TS9 connectors, so it looks like they may be an issue with the TS9 ports on the CPE Pro. 

https://www.youtube.com/watch?v=F8Jh_HV3_Tc

As with any mod, this will void any warranty on the unit, not to mention the high cost if it goes wrong.  On the positive side, it doesn't require any soldering or drilling, i.e. just unclip the internal antenna leads inside and attach the external antenna pigtail leads, which you can pass through a ventilation opening on the top or base. 

The internal connectors have IPX plugs, so you would need two of these (or similar).  If you find other listings, check that there's a centre pin in the picture of the SMA plug as there's a similar IPX to RP-SMA pigtail for Wi-Fi that doesn't have that centre pin. (Correction: I originally linked the wrong product with an SMA male plug instead of an SMA female)

https://www.ebay.ie/itm/1-13-Cable-RP-SM...2646404414
Reply
#42
OKay so literally, changing the setting from internal to external does nothing, signal doesn't disappear or anything, it just stays the same , are they even functional like that option ?? I took the router up to the shed where its higher up,(  https://i.imgur.com/pVZbyKV.jpg  )  you can kind of see the tip of arranmore in the distance. Using its internal antenna. It does show 5G here, but its almost like a fake 5G Big Grin speeds werent impressive, 100 on nperf , just looks like typical 4G CA. But then again that was with internal antennas. But anyway I dont know what any of the readings in Hmanger meant. It doesn't list 5G NR readings anywhere, only band 1 LTE or band 1 CA. and it's showing as 5G. I took a bunch of pictures here in album below 

https://imgur.com/a/BQugJHd
 
I'd organise them better if I wasn't running around trying to get this to work Tongue 



The TS9 to sma connectors I have are https://www.maxbitt.ie/rp-sma-female-to-...1539k.html  
got them from here when I was trying vodafone. There is no male pin on the adapter , its just a SMA female with male TS9 connections. 
I wonder why they don't work, is it cuz they dont have a pin in the center? but how would they connect to the antenna connectors which are male pins, confused Big Grin 

The 5G speeds weren't impressive, though was it even 5G, it says band 1 but has 5G on the right, theres no info on the 5G, but the 5G signal always matches the 4G one , i mean on the huawei router homepage, the signal bars match.  Max speed tests on nperf are what felt like a cap at 100 mbps. 

I did have the 5G light on though, whenever i'd select that. Setting NR as the RAT wouldn't work, but it would work in LTE with band 1 seeming to be the thing that enabled 5G/makes it show up.

What do you think I should do? I can either refund and try find a router that supports 5G and supports antennas, or I can try this modding, if it means the antennae would work. The antenna function doesnt seem to work at all.
Reply
#43
Those TS9 to SMA pigtails appear to be fine. I made a mistake above as I was thinking of the antenna lead connector end instead of adapter's SMA. Indeed this should be a female connector without a pin in the centre where the SMA connector (with its centre pin) screws on to.

It's a pity the Apps are not showing the NR signal readings to confirm. You can try selecting "NR" for the RAT in the HManager screen. This may force it onto 5G-only mode, although it may not connect. If it doesn't connect, you can try selecting Auto again to see if it shows the NR reading.

Another thing you can try is selecting one LTE band at a time, e.g. 1, then 3 and finally 20. If it shows 4G and 5G lit for band 20, try a few speed tests and repeat with just LTE selected for the RAT. If the speeds are substantially higher over with 4G and 5G, this will confirm that data is being carried over 5G. Otherwise, I wouldn't risk trying the mod until you are able to confirm it is properly working over 5G.
Reply
#44
What I remember from trying something similar, I selected each band invidually, and it was listing them as LTE like this https://i.imgur.com/R6lQNW3.jpeg
But every time I choose band 1 it will connect as LTE and 5G. It only seems to be band 1 it happens on. Ill try go and get that done quick.

https://www.ebay.ie/itm/IPX-IPEX-to-SMA-...i#shpCntId

Are these okay?

Is there a reason 5G light only shows up with band 1 ? Kind of odd. I'll redo some tests now quick
Reply
#45
That is interesting as it gives the impression that Three is only pairing 5G with band 1. This might also explain why the network kept trying to get your Chateau router to switch to band 1 as otherwise the CPE may not have tried aggregating with 5G if it was connecting on band 3 or 20 as the primary. This also rules out any chance of picking up a distant 5G mast from my location as I can only connect to band 20 as the primary band with the distant masts I pick up.

That connector should also work, but just make sure the TS9 ports are less than 15cm from the top or bottom. Otherwise those leads will not be long enough as the motherboard's internal connectors are directly behind the TS9 ports.

This is another alternative with a 30cm lead:
https://www.ebay.ie/itm/1-13-Cable-RP-SM...2646404414
Reply
#46
So basically, it felt impossible to tell the difference between the speeds on the Auto RAT -  band 1 5G mode or the regular band 1 LTE mode.
If I select band 1 and use the RAT auto option, it will always connect into the 5G  networkmode. If I select LTE it will connect as LTE network mode. 
I'm not sure if the 5G network mode is actually making a difference or not because speeds were pretty much similar from what I could tell anyway. I took a bunch of screenshots again with different combos. Real shame the antenna option is essentially just not even functional. If you change antenna to external it will still just use it's internal ones since If I move the router off the window with them plugged in. It'll just go to no service. 

If I select NR as RAT on any band it'll say no service. The CA options also seemed pretty poor , mainly 2x CA from what I could see that would work. If I set the RAT to auto it'll only show as 5G network mode on band 1. If I do it on any others it'll be "LTE"
You can see a bunch of combo's in these screenshots: 

https://cdn.discordapp.com/attachments/6...212218.jpg
https://cdn.discordapp.com/attachments/6...212520.jpg
https://cdn.discordapp.com/attachments/6...220023.jpg
https://cdn.discordapp.com/attachments/6...215951.jpg
https://cdn.discordapp.com/attachments/6...Chrome.jpg
https://cdn.discordapp.com/attachments/6...Chrome.jpg
https://cdn.discordapp.com/attachments/6...Chrome.jpg
https://cdn.discordapp.com/attachments/6...214818.jpg
https://cdn.discordapp.com/attachments/6...215018.jpg


Do you think it's better off to just try refund the router and find another that will support SMA/TS9 antennas without this stupid issue? 
It does say on cloves website I can try a product for 14 days and return it if I don't want it. 
Are there any 5G routers that are confirmed to work with antennas? Not sure what is wrong with this one

Is it possible that it's not even 5G? considering the speeds are quite similar. Or is it simply just because I'm not getting a strong enough signal with the internal antennae for the 5G network mode to have an impact. I had a feeling like it was mis reading band 1 as 5G. But it did show the 5G light when it turns on , even after a factory reset , sitting on the shed window, the 5G light comes on after a few sec and it does list 5G on the huawei signal page , but it always matches the 4G's signal bars.
Reply
#47
For curiosity, I put your screenshot into Google Translate to see if could translate those Chinese characters:

   

I presume that "5G not excited" means it failed to establish a connection on 5G, much like getting a 4G signal but failing to connect due to an incorrect APN.

If you are using a different SIM card to the last day, make sure it also has the 5G booster add-on.

Try changing the APN to 3ireland.ie if you are using 3internet.  As Three has not officially launched its broadband plans, it's possible their network may not allow a 5G connection with the 3internet APN.
Reply
#48
I'll go take a run back up to the shed and try it now Big Grin Btw https://blog.netgear.com/blog/nighthawk_...available/
It got released 10 hours ago according to post, found reddit post about while crawling the web for new routers, I suppose it'll be locked if I tried to get it from there? Seems like an exclusive but i'd imagine it has features like band selection and stuff right?
Reply
#49
The Netgear MR1100 and MR2100 (models M1 and M2) both have band locking capability from the terminal using AT commands.  I presume the 5G model will have something similar. 

However, I would not recommend trying to import that AT&T model or any other 5G router from the USA.  Most US versions including that Netgear 5G model lack 4G bands 20 and 28.  It is also very likely network locked as I have heard of other networks locking their own MR1100 and MR2100 models, such as EE in the UK. 

If 5G still does not work after trying the APN, I suggest returning it as otherwise it's very risky modding it not knowing whether the 5G is not connecting due to a weak signal or if the unit itself is faulty.
Reply
#50
Yeah no luck I think, like when I put it on the window and turn it on , with all band selections and things gone cuz I factory reset it, it'll instantly go to 5G green light but the thing still shows that "not excited" thing Big Grin 

I managed to get the letters for that,  未 激 活  , from what I can find on google it means either "inactive" "not activated" something like that ... 
[Image: 6CcGBKe.png]

Tried resetting to factory settings and only setting an apn - 3ireland.ie so I cleared any control from the app selecting/forcing bands/modes etc.

The router would still show like this with 5G signal:  https://cdn.discordapp.com/attachments/6...172709.jpg 

Also 5G signal here: https://cdn.discordapp.com/attachments/6...Chrome.jpg

And then I opened another Huawei manager version in English: https://cdn.discordapp.com/attachments/6...014350.jpg

And in the other it shows the chinese version/pther stats:  https://cdn.discordapp.com/attachments/6...003748.jpg


It would also just go into 5G mode/light when I select auto mode in that huawei manager too. Always band 1, If I select auto as the RAT on any other band it'll be "LTE network mode" 

Does that mean it's got 5G signal but not able to use it? Like maybe three blocking anything that isnt a phone? Idk I have no idea, going by above it means "not activated/inactive" so I wonder what that means, I did have 5G add on enabled on both sim's I tested. Unless theres some new apn/ apn settings that need adjusting on Three's end? Vodafone used to "refresh/redo" settings on their end, maybe that helps something but I doubt it. Otherwise I have no clue what the issue is , and thats not even getting started on the antenna options/functionality being completely useless/not working at all. I saw on cloves website now they discontinued it Big Grin  https://www.clove.co.uk/products/huawei-...fi-hotspot

Maybe it's just the router model itself and being faulty - probably rushed manufacturing because its one of the first 5G routers around, worked out at basically 500 Euro including shipping. Bit too expensive for something that doesn't work, I already sent an email to them enquiring about the issue / basically leading up to my refund. I'll see what they say.

In the meantime is there any other 5G router worth trying/taking a look at, can't seem to get that MR5200 anywhere, one place has it for sale "4gstore" but it has "specs unknown" in some parts which makes me think it'd be like a pre order. 800$ too.


I really hope I can get something like the MR5200 / smth similar. I tried like "internet" "3ireland.ie" "3internet" "open.internet" , even tried another sim and used 5e balance for the 5G add on again, it still doesn't work Cry I think if I had actual antennas it'd be able to pick it up . Considering I basically only get band 20 and 28 signal with 1-2 bars on my window at the house without using any of my external antennas. Which to use my B525 as an example-  RSRP goes from -116 on band 20 to -89 RSRP with  the LPDA 92.

I'll try see if I can find any other router that has antenna ports. No idea why it won't connect though either, 5G signal matching the 4G one, like as if it's thinking band 1 is 5G. But when you select band 1 in LTE mode the 5G light will go off... Idk what it even is or how to explain it. It goes against what I read on the ericsson website about "deployed on 3700 Mhz and 1800 Mhz in Ireland ) Do you think anything will change in the way it works  when they roll out their 5G broadband plans?, saw a Three rep say on their community thing its "coming soon".  

Saw post on 3community saying the same thing , using a CPE pro 2: 

"Hi there,
  am looking for some help. I have bought a new 5G router and I am getting a full 5G signal on the router but I am not getting 5G speeds.
 I have added the 5 euro top up to my account and bought the 5G service but nothing. I have checked the eircode checker for 5g and it says I am in coverage"



I'm gonna give it one more go before I go to sleep and if it's still not connecting i'll just refund it since I cannot even use the antennas on it. 
Also I saw verizon in the US was using 700 Mhz to assist coverage for 5G, and its standalone. Will they do something like that here?
Reply
#51
To make matters even worse, the cell ID's have changed and the signal have dropped dramatically on band 3 and band 1 using my LPDA's , I woke up this morning to see the cell id is now 257 instead of 1  and the signal is awful. Knowing my luck now even my 4G performance is going to dramatically drop too Cry
Im going to go setup my LHG 4G to see if my band 3 has also dropped there.. had it down yesterday to test the sim from it. Will retry 5G again incase anything has changed

Signal before: [Image: hvW2YVw.png]

Signal after:[Image: rw1AftV.png]





I woke up to see that B20 was working and aggregating band 3 again but the signal was tragic. CA is now working again but its not much good when its -115 RSRP Cry
Would there be a chance they're doing maintenance or will this stay like this? band 1 does show up if band 3 is the uplink but I can no longer set it as primary because there isnt enough signal. It's cell id remained on band 1 for a bit but now it's also 257.

Got a reply on twitter saying there is no works and its up and running... then why would the cell ID change, I noticed sector ID also changed from the usual 31 to 2. 
Back to the old signal I used to have, unfortunately means streaming is not an option either , upload has went from 25-35 to 6 or 7. Sad really. I dont even pick band 1 up as the primary anymore, no signal, only on CA.

Reply I got : 

"I've checked on the mast on Arranmore & the masts nearby on the mainland & there's no works or maintenance going on on any of them. There have been no changes made on the masts either."
My brothers signal has also gone, he tried to download a game update and band 1 was completely gone, it was his main form of speed so he had to use 3G.
Reply
#52
Pity to hear about about still not connecting over 5G. To me it looks like it's getting the 5G signal, i.e. where it shows 5G and 'Live' for the translation, but just not establishing a data connection over it. This is what led me to think it's an APN issue, but now looks unlikely with you trying the lot. For example, with the Eir 4G network which is more strict about the APN, the Huawei B525 router will show a 4G signal, but "Not Connected" as the status.

Another idea that comes to mind - Check if you have an in-car 12V DC adapter that will fit the Huawei port. This way you can try driving further west towards the island to see if the router CPE Pro connects in the car. This will also determine if Three has a shorter maximum range limit on 5G, like how I cannot connect to 4G bands 1 or 3 as the primary band.

From my limited searching, I haven't come across any other 5G routers sold within the EU other than the CPE Pro 2 and the Huawei Hotspots, which all lack antenna ports. However, at least now we know that the router can be modded easily and having seen a CPE Pro 2 disassembly video, it looks like it can be modded in the same way. I just didn't know what connectors it used before until I saw the video yesterday that mentioned that Huawei uses IPX connectors on the motherboard.

From what I recall reading, the mobile networks will use 700MHz band for 5G once ComReg carries out the multi-band auction next year. However, like the 800MHz 4G band, the 700MHz band will likely only carry 10MHz of bandwidth per operator. This means it will not be much faster than what you can get on the current 4G signal running on that band. This is very different to the 3.6GHz band where Three has 100MHz of spectrum, i.e. 10x the capacity of what the 700MHz band will likely provide.

To me, those Cell ID changes and drop in signal gives the impression that they are working on the mast again. Generally they turn down the output power to make it safe for technicians to work on the tower.

I also wonder why Ericcson mentioned about 5G being deployed on 3700MHz and 1800MHz, especially with Three trying to hand your routers to band 1.
Reply
#53
They completely deny any works on twitter this time. I hope they dont like lower the power now on purpose or something, it was working amazing on 4G up until today. 
The thing is, if I cell lock now using the LHG 4G , I can cell lock to cell id - 1 but its way worse signal, and if I let it auto choose without any locks it'll be a different cell id and slightly better signal.. but still terrible compared to what it was. 

It's basically indentical to what my old signal was in a way. Ill show example of what I mean. 

No cell locking- automatic connection: 

[Image: YOOYpWB.png]

Cell locking to the o2 band 3 mast on ID 1: 
[Image: 6Rh0kex.png]

I really hope this isn't permanent, would be a disaster to get used to such great speeds and then have it taken away Cry 
My brother cant get his college work done either cuz he was using band 1 4G and now it's just gone completely. Speeds are also terrible from any that i've done, even in triple CA. Only one that works well is B28 and B20 which appear to be unchanged. Their signal remains around -89 RSRP.

I'll go try 5G again now to see if anything changed, doubt it'll work at all now but may aswell try, since CA works again. Something definitely changed I just dont know what.

Tried 5G, It's just 0 signal bars of band 1 , network mode swaps between 5G and LTE depending on RSRP, basically -124 RSRP on the window, huge drop in signal compared to before. Would there be any reason they'd lower the power like that out of nowhere other than maintenance? Frustrating week internet wise. They deny any changes/works on twitter  Dodgy
I suppose they're not still working on it at 7 when its dark, signal still bad. I'm afraid of it becoming a thing that wont go away  Confused
Reply
#54
That's a shame to see you aren't getting any 5G connection. Is that due to the router itself or is that just the area you're located in? Given that Three told you there are no works ongoing in your area it's probably not that. It's strange because in that Boards.ie thread someone posted a screenshot of speed tests on their 5G phone and they got around 500Mbs download. One person on that thread with a CPE Pro said they were getting speeds of 220Mbs, which is doable on 4G+ and comparably low for 5G standards. Could it be possible they're throttling/blocking 5G routers from using their network until they announce their 5G broadband plans?

I was considering purchasing the CPE Pro from AliExpress but seeing it not work for you as well as the antenna issues is making me think twice about it. Sad Perhaps I will hold off for another while and see if you or any others manage to get the 5G working. I wouldn't want to go buying it now just to have it not work for however amount of time when it could be cheaper by then or have better alternatives on the market.

One way they could be throttling it is by checking the TTL values, though I'm unsure how you would go about modifying that on the CPE Pro. (Assuming Three actually are blocking routers from 5G.)
Reply
#55
That's actually a good point as there's no screenshots either of the signal readings.  For some reason I thought those 500+Mbps test results were from a router, but not the case having looked back at the thread.  Indeed 220Mbps is capable even with just dual carrier aggregation, e.g. 1+3 or 3+3 aggregation as I got back in August in Letterkenny with my 4G HTC U11 phone.  My phone doesn't support triple carrier aggregation:

[Image: 6438378725.png]

I don't think they are blocking by TTL.  For TTL-based blocking to work, there would be a firewall that checks the TTL values in the packet headers.  However, as the data connection is not even establishing over 5G, there are no packets flowing to even check the headers of.  However, if they are blocking routers from accessing 5G, it could be based on deriving the device type from the IMEI number, which the network can see.  For example, if you type your IMEI number into the imei.info website, it will show the device type (router, phone, etc.), brand and model.

Hopefully they restore the signal strength soon again.  At my end, the signal readings remain unchanged from the distant 4G+ site I'm connected to.  Although I'm sure unrelated, our electrical voltage has been running low most of the day, i.e. My PC's UPS gave a frequent under-voltage alert with the readings varying between 200-210V from around noon until 8pm.
Reply
#56
I tried TTL blocking workarounds to rule it out with the mikrotik router a while ago... Some ISP's in america use that for throttling on tethering.

/ip firewall mangle
add action=change-ttl chain=postrouting new-ttl=set:65 out-interface=lte1 passthrough=yes  command would change it via terminal on my LHG 4G

https://www.reddit.com/r/hacking/comment...hrottling/


I guess all I can do is try complaining to them? I doubt it will do anything either... It's a shame really. Especially when they're denying anything is wrong.
Would they lower the signal to be more compliant with some kind of law? Or to save money? Or idek it makes no sense as to what happened.  The cell ID-1 is still is there if I cell lock to it's just much worse signal than letting it connect automatically, its as if the sectors have changed or moved around /  that the sector aiming  in my direction lost half of its broadcasting power... Dodgy  Why else would the cell ID's change over night, and suddenly the carrier aggregation is working again...yet there was apparently no works done. Isn't that odd in itself  Huh
Makes no sense to me. Whatever chance I had of 5G is out the window now... If I can't even get this 4G signal anymore  Angry  Yesterday I was picking up 5G now I can't even get a decent 4G signal. I didn't expect to get that bad.
Reply
#57
Hopefully this is just temporary as I can't think of why Three would run a mast on very low power other than for maintenance or to rule out a possible interference issue in another location.  It's like the issue you had earlier in the year after one of the storms. Cry

The only suggestion I can think of is to get your brother to complain to Three and the same with anyone else you know on their network in the area.  They probably need complaints from multiple users to take the issue seriously.

I still miss the earlier years with Meteor 4G where when I called about an issue, the person at the other hand could perform diagnoses from their end.  E.g. I remember in Ballybofey calling about an outage, the person on the phone remotely rebooted the mast and my coverage came back briefly and went out.  The person then said we'll send an engineer to check the site and it was back the next day.  Once Eir took over Meteor, the technical support went the way of Three and Vodafone, i.e. the usual script based approach - Try taking restarting your phone, try the SIM in another, ... ignoring my specific issue. I ended up leaving Eir over that.
Reply
#58
The cell was completely down all day, nothing at all coming from it since 9:30 this morning according to the last link down time, it just came back about 6.30 pm but still a low power/bad signal. Is there a chance they're just putting it back on half power/broken equipment till tmoro again till they actually fix it, or will that be it up permanently like that I wonder...  I wish support was like that, it's usually just fobbing you off with reboot your phone/sim stuff. As for the 5G router, I was hoping today when it came back that it might work this time... Though the way it came back to the same broken way it was I'm doubtful. It was exactly 9.30-6.30pm it was down for. So its like normal work day Big Grin

Ordered the ipx to sma cables just incase it happens to work on 5G, i'd nearly just mod it in the meantime if the 5G will work from the window.

Actually I discovered that the reason triple CA is probably working is because i'm connecting to another sector on the cell 257 , and it is operational. That would explain the poor signal right? Bad angle of getting reception? 

I can still pick up my old cell ID-1 if I cell lock but signal isn't usable, (maybe something happened it?) and if I try doing triple CA, that issue I mentioned that started the day I got the 5G add-on makes it link up and link down loop indefinitely. So that isn't fixed on sector 1 either. I wonder why the signal would die off though.
Reply
#59
If this weak signal remains tomorrow, I suggest trying with a separate antenna (e.g. one of your original LOGs using antenna port #1) to see if that signal on cell 257 is coming from a different direction just in case Three set up a new mast recently in another nearby location.

I still think Three is doing something with the Arranmore mast especially with you mentioning that it was out from 9:30am to 6:30pm. These times indeed seem too coincidental to be just a mast fault.
Reply
#60
Yeah i'll give that a try, Though I think the signal that was showing up today was from dungloe, I remember that 57 cell ID from before. Anything else would be in Gweedore direction but the hills block that completely. I'm praying that they fix it tmoro and it also fixes the 5G, I see everywhere else in Ireland has nperf tests around their 5G sites, but not arranmore. So maybe there was an issue to begin with.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)