Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need help. 4G only connects with roaming enabled
Sorry if this is a stupid question or has been answered already on another post, I'm very new to all this!
I have a SIM unlocked Huawei E5577 (originally got from Eir) with a Three data SIM. It works fine when using 3G, but as soon as it switches over to 4G, I lose connection and get an error message saying I need to enable roaming. 
I've tried adjusting APN settings but no joy. 
Any help is greatly appreciated!
Welcome aboard Smile

Three bought out the former O2 a few years ago and continues to use the former O2 network code (272-02) on some masts. Some modems particularly with older firmware still treat the 272-02 network code as a separate network from Three's native network code (272-05).

Based on your description, this is very likely the culprit, i.e. try turning on data roaming. Check the network name that appears when it connects. If it shows "O2 Ireland", this is the former O2 network name, but now using the Irish Three network. If however it shows "3 UK" or any other network with 'UK', then it is roaming on a UK network such as if you are near the border.
Hi Sean. Thanks for getting back to me. 
Seems to be working fine on 4G once roaming is enabled. Suppose I was just thought it was strange I'd need to have roaming turned on in Cork. Thought something had gone haywire. 
I appreciate the help!  Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)