Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Automatically enable Ethernet port on MikroTik LHG, SXT, ATL, etc.
#1
Whenever the modem in any MikroTik router loses internet connectivity, I usually disable and re-enable the modem just to rule out the modem being in a crashed state, an issue I occasionally had with the Chateau LTE12 modem.  

One day when I lost the Internet connection on a MikroTik LHG at work, I tried doing this only to realise I clicked the ether1 interface by mistake and sure enough I realised my mistake when Winbox dropped out . . . Confused  With just one Ethernet interface on the LHG, I was left with no choice but to do a factory reset as the Ethernet port just remained disabled after a power cycle.  Resetting an LHG or any other outdoor MikroTik router / CPE involves pushing the reset button on the actual unit.  Luckily the LHG was setup pointing out an upstairs window and not high up on the roof!

To avoid a similar situation in future, here is a guide on how to have RouterOS automatically enable the Ehternet port on start-up.  This way if someone or something disables the Ethernet port, it is just a matter of power cycling the router to re-enable the Ethernet port:
  1. In Winbox, go into System -> Scheduler
  2. Click the '+' to add a new schedule.
  3. Give it a name like "STARTUP".
  4. Click the drop-down arrow to the right of the Start Time field and choose "startup".
  5. Enter the following code into the "On event" field:
    Code:
    delay 30
    /interface ether enable ether1
  6. Click 'OK'
The "delay 30" line waits 30 seconds to make sure the router hardware has fully initialised after booting up and the following line enables the ether1 Interface, which is the first or only Ethernet port on MikroTik routers.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)