Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
4G and 4G+ testing
That's great news seeing band 1 come online.  I'm actually very surprised that they are adding more band 1 4G sites as they are now over 2/3rd they way into their temporary 4G spectrum licence, which expires within two months (8th October).  As it doesn't really make sense to set up a new tower for just two months, this could also be a sign that they may get a licence extension. Smile

As you mention you had packet loss on Vodafone, it looks like this is a major backhaul issue as it is unusual for an issue to affect all three networks, especially over a wide area. I noticed the distant 4G+ site I was using is down as I write this post.  It means I can't do a packet loss test at the moment as our local Kilcar 4G mast doesn't seem to be affected by packet loss.  [Edit - I spoke too soon, it is affected Confused ]

   

It makes me wonder if they are still doing upgrade works at the moment.  As you mention that your IP address is changing every few seconds, it looks like their mast has a power amplifier issue affecting band 1 and 3.  Hopefully the engineers spotted this before heading off, unless they are still working on the site.  I certainly never the signal strength bobbing up/down in LTEInspecteur like that, however, someone did contact me a few weeks ago with a similar issue but on 3G.  They had a new MikroTik LHG dish router, so I assumed it was that and they ended up returning it within the 14 day cooling off period.

If the issue remains tomorrow, try locking the band 20 cell as the primary cell with your Chateau LTE12 and the other two for carrier aggregation.  This way it will maintain the connection over band 20 including your upload.  The speed however will bob up & down during each cycle, so I'm not sure how much this will affect the latency while you are streaming. 

Try also setting your Chateau to band 28 only.  If they are using that temporary band in Dungloe, there is a very good chance you will have it all to yourself. Big Grin  The Huawei B525 does not support band 28, so only those with very recent smartphones or third party routers can use it.  The MikroTik LHG dish antennas don't support LTE band 28, however, the Chateau LTE12 does.  

Hopefully this all stabilises as I'm curious to see what you get with with all three bands aggregated.   Cool
First of all, I went down the field and took down the R11E4G that was on vodafone since I was getting such good upload speeds on Three now. I put the old LTE6 with the vodafone sim in its place so I can check vodafone anytime I want to see if they do any upgrades to dungloes cell. I put the R11E4G up in the tree beside the LOG's aimed at arranmore and there definitely an upgrade done to all the cells. They all have new cell ID's and their signal is even better before. Ill leave a few examples in links below but to give an idea, I used to get -108 RSRP on band 3 using the R11E4G now i'm getting -89 RSRP  Big Grin . Latency seems to be better on all bands before , using carrier aggregation as well. I remember it used to add a lot of jitter and latency if I was playing using 4G+. The LOGs signal as an example of improvement, old signal was -114 RSRP and the new is -95 RSRP. The engineers must've spotted that issue because theres no more intermittent lag/signal fluctuation like yesterday which is also great. They did say there was more work scheduled for today when I was enquiring about why I had no signal. The speedtest.net tests I did at 5am were slower than the ones I did around 2-4pm today. Maybe they did something to give it even more speed idk Big Grin
The SINR as well seems to have increased dramatically on the higher frequency bands, 18-26 even which is the highest I've seen. Band 20 is still lacking with about 8-14 randomly. I assume thats because  the band 20 one is heavily loaded since it has the most propagation. 

I tried band 28 but nothing showed up Cry is it in use anywhere in ireland? And what are/would the speeds be like? 


To make matters even better it solves all of my streaming problems now that the upload is ranging from 28-40 at times and its consistent all day all night, unlike vodafone where it would have insane packet loss and latency in the evening and just a bunch of dropped frames and other nuisances. The consistent speeds I was happy about on vodafone also began to deteriorate abit and i was no longer getting a consistent 80-90 down but more like 40-60. 


Heres the signal readings + new cell ID's : (Using  LPDA 92 LOG antennas) magically appear to work now ... maybe Three's cells were the problem?

Band 1 : https://i.imgur.com/ob4ZBPx.png
Band 3 15Mhz: https://i.imgur.com/V3fCXcD.png
Band 3 20Mhz: https://i.imgur.com/zyvQwDw.png
Band 20: https://i.imgur.com/23RPuQP.png 

R11E4G Band 3 Signal: 

15Mhz Cell: https://i.imgur.com/TtNbunS.png
20Mhz Cell: https://i.imgur.com/si3yZ52.png
3G signal has also returned to normal on band 1 pretty much, -94 RSCP

You can see the signal improved drastically on all of them except for band 20. I wonder what they did overall. The band 20 cell is still heavily loaded by the looks of it, 2-5 mbps down and 14 ish up. same as before but the rest have a massive improvement in terms of signal plus its the first time I got to test band 1 Big Grin I really hope they do get an extension, would there be a chance it'd be permanent or made that way somehow? it is weird they upgrade a band 1 cell now this late into their licence.  

As for speedtests , I was really happy with it, I saw insane speeds last  night at like 4-5am. it peaked at 300 Mbps on a vultr download Big Grin and stayed a consistent 200+. I was using band 1 as the primary link and band 3+3 as ca bands.  Downloaded a 1GB test file in no time. Speedtest was always 100+  and the upload was solid too. Ill show some examples.  I was wondering what site I can use to test the best of its abilities, to avoid traffic shaping and stuff, I definitely notice some kind of weird speed decrease in speedtests in the evening today, It starts on the screen at 100 Mbps + but it'll drop down to 50, like gradually losing speed the longer the download. Have a look at these, most of them were even done in the day around 3-4pm 
[Image: pdzJq8V.png]

And on vultr I was getting results like this :  Peaked at like 300 Mbps Tongue  I'd love to get to try it on server like colorado springs on testmy.net but it wasnt there.
 [Image: cLwtKyz.png]
[Image: 1K1UbyZ.png]
That sure is a huge improvement on the band 3 signal.  It makes me wonder if Three's equipment on the mast had deteriorated, especially with how things got after the last storm.  The new cell IDs clearly indicate they upgraded the radio equipment.  At least your Chateau and LPDA antennae are finally usable and sure hope it lasts this time.

As you get carrier aggregation with bands 1 + 3 + 3, I wouldn't worry about band 28 or 20 now!  Band 28 is another band they got temporary spectrum on in the 700MHz range, however, they are only using in a few areas so thought it was worth checking.  This was spectrum freed up from the UHF TV band with UHF channels 49+ recently moved to lower numbers. 

300Mbps sure is an impressive achievement especially on the Three network.  Looks like Vodafone has some catching up to do... Tongue

I'm not sure if Three spotted heavy traffic from that Dutch Vultr server as it was not prioritised earlier today, at least not with several test runs I did.  How many times have you downloaded that 1GB file?? Big Grin The UK, Paris and German Vultr test files are still prioritised.  The Vultr NL site seems to be prioritised again this evening. 

From what I can tell, it looks like the packet loss issue has been fixed.  I have run several lengthy ping tests and have been getting a near-zero packet loss, 0.1% in the last test I did about 9pm.  Over the past few days it was often over 10% by 9pm, sometimes making it very difficult to hear the other end on our VoIP line.  With a ping test started at 11pm, it did not have a single lost packet when I stopped it after 2000 pings.

So far the only reliable way I found to get past traffic shaping is with the Hide Me VPN, configured with the OpenVPN TCP protocol.  While the SSTP also gets past traffic shaping, the OpenVPN TCP protocol gets much closer to Vultr's performance.  Speaking of Vultr, it has been getting over 100Mbps here this evening, the first time I've seen it this high on the distant 4G+ site at this time of evening.  Even the TestMy UK server is 10x faster than what I usually get at this time of evening, so Three has definitely been doing some sort of upgrade works.  Just wish the Chateau didn't have the flapping bug when using cell lock here. Confused

Vultr NL test:

   

TestMy with the UK server and again over the Hide Me VPN (Open VPN TCP protocol):

[Image: QMaHmY6y4.png] [Image: tGXYUOVR8.png]

So far I haven't had any update from MikroTik on the link flapping issue other than them running diagnostics a few weeks ago.  If they are unable to fix the link flapping issue soon, I may get a separate SIM for running our phone on.  If I use the Chateau in LTE pass-through mode with another router, the link flapping just causes latency spikes and would mean I could use it for high speed downloading / streaming and the other connection for our phone which needs the low latency/jitter.
(27/07/2020, 07:03 PM)SmK Wrote: Ok, thanks, I have three days left where I could return it to Amazon but will try and contact them first to see what they say, there was an option to update the dish within the phone app and I updated it last week, was having the same issue before the update, haven't checked if there is one available since

Hi, I never returned the dish, MikroTik requested a few supout files which I sent them, they said that the drop in signal that the app was showing didn't show in the file, and they couldn't understand why 4G wasn't working,
I have the dish set to 3g only and bands 3 and 20 ticked, this is the only way I can receive anything worth while, it's been really poor in the last few days, in the last few weeks it's normally about 6-8 down and 1.5 up, when i last looking at it I seemed to be hitting two cells on arranmore?
https://imgur.com/a/qTadMs6
https://imgur.com/a/8T2Dohe

And as Emilia says they have different codes now, the internet was still nearly unusable last night,

Going by what Emilia says, should I stick with 3g only and bands 3 and 20 or try something different? Although he's not using this dish there might be something I can try?
For Arranmore they upgraded all the cells for LTE thats why the cell ID's have all changed. Your LAC (location area code) is the same as mine on 3G so its arranmore I reckon.  The band 1 3G on Arranmore is fairly good and thats what I was  using up until 2 days ago when they started upgrading everything.  I'd give that a go. Depending on what model mikrotik dish you have...? The R11E4G in my case I have doesnt have band 1...  If it has band 1 available on LTE you can try that since they're just after adding it 2 days ago, its about 30-50 Mbps on that band alone. If not I'd try band 3 and see if you get any signal on that. Arranmore has two band 3 cells you can connect to - One old repurposed o2 cell and Three's own one.  EARFCN 1275 + 1700. 

I found using band 20 on the mikrotik to be useless almost , it always has better signal on band 3 compared to band 20.  I think the antenna is designed for higher frequencies like band 3 + 1.  I had the same hassle sending supout files to support when the R11eLTE6 had major ping spikes/jitter  where I couldnt use it to game at all. And voip wouldnt work properly either. Spent ages upgrading routerOS and the LTE firmware to see if it'd help matters , support said theres nothing they can do either So I just gave up on it . I have it down the field atm aimed at dungloe with a vodafone sim so I can keep an eye on their network to see if anything changes, thats the only use I found for it Big Grin  I even went and bought a brand new one again hoping it was just a defective unit... both have the exact same problem and support deny it. I reckon that LTE6 device is faulty , every single one of them, The signal readings if I recall correctly would also read badly. For example, It'd say -100 RSRP then drop the -54 RSRP for a second then back to normal again (which is obviously impossible to have -54 RSRP on a mast 14 Km away). It also over estimated the actual readings. Another example would be, my R11E4G would get -108 RSRP on the cell, and the LTE6 in the exact same location would read -100 RSRP. I definitely think that unit in general  has some kind of manufacturing issue and they refuse to acknowledge it. 


 The R11E4G and the chateau LTE 12 router seem to work good tho. So for Arranmore in my opinion your best bet is band 3 and band 1 for LTE.  And if you still get no signal there, For  3G , at least speed wise I'd try get band 1 to work since it's a higher frequency and its also just faster , the mikrotik also performs poorly on  the other 3G Band in my case unless you have a different model.

The whole arranmore network went down  this morning for  a few hours and I noticed I was picking up  a few  new LTE cell ID's I never saw before with poor signal. I reckon  they also are performing upgrades in dungloe and it increased the signal range for those too. The signal was weak because my antennae are all aimed at arranmore but I'd say if i aimed them toward dungloe now i'd start picking up a decent signal. I never used to get any form of signal from dungloe at all. If you can get line of sight to dungloe try aiming it there as well. 
It'd be worth keeping an eye out for signal in the gweedore direction too, they have some masts in dore and on top of dunlewy as well. They definitely appear to be doing a lot of upgrade works lately so signal/speeds might change soon ish. 


Aside from that I went to buy premium hide.me vpn so I can try bypassing Three's traffic shaping. I saw the pricing and it said 5 euro a month or (130 euro) for 2 years. I went and bought it and it charged me the 130 euro at once Big Grin   The whole thing was poorly worded.  Is there a monthly option on their pricing I wonder? At least if it works as intended. I can download things at high speed regardless of what time of day it is on the SSTP/Open VPN protocol. 



These were the new cells I never saw before while the Arranmore network was down, so they probably added band 1 + better band 3 cells to Dungloe as well. 


[Image: gPULF16.png]

[Image: 4lBWLRw.png]

[Image: ubPkEAP.png]
Hi, thanks for the info, I have R11eLTE6 model so don't know if that's my issue cos as you said the support guy didn't really give any answers, I have a clear run to arranmore but not to Dungloe, I'm not up on it all but when I looked at the graph on the app, I was getting readings of -73 rsrp and 6-8mb/s at its best, then when it went to -93 the internet was unusable, shouldn't -73 rsrp give you a good connection?
I'll try band 1 and see how I get on, I'd totally given up on LTE because I was getting nothing on it, don't know if that's cos of the dish though,
Cheers
-73 RSCP on 3G band 1? or -73 RSRP on an LTE band? Either way, that's a good signal for both networks. Even -93 RSCP or RSRP  is fine. I'm not sure why it would become unusable because that is still adequate signal, thats about what I get on both 3G + 4G.  But It shouldn't be fluctuating like that, unless something is temporarily blocking line of sight and becoming free again.
To be honest, I have had a terrible experience with that LTE6 model and I wouldn't be surprised if it's faulty at all going from what happened with both of mine Big Grin . I bought the older R11e4G and it did me well. Though if I were to buy again I'd get the R11eLTE version so you can get more bands like band 1 for example. I dont get that on the R11e4G. 

If you get access to a laptop/pc , try going to 192.168.88.1 and going to the terminal and typing in this command. If you download winbox and connect to it via that, you can just copy paste the command into the terminal there instead of manually typing it. Handier. 

/interface lte firmware-upgrade lte1 upgrade=yes


It's worth a try upgrading the LTE firmware to see if it makes any difference. One other thing you can try is going the tabs on the left on the webfig page , and going to system - then packages and try updating routerOS to the latest stable version. The experience I had with support is they just checked the supout files, and said they'll try recreate the problem and get back to me but that was months ago at this stage.

I dont have line of sight to dungloe either but I still get decent signal from it, you can try aiming it there anyway for the sake of it to see if you get anything since they definitely have increased their signal range. I'll do a bit of testing myself to see exactly how much they've done.
Strange , The cell went down for about half an hour yet again today, and I noticed some further changes they made, Why would they be doing work on it almost every day? Take a look at the Cell ID's. They changed them back to the old cell ID now which was 1. When they added the upgrades they were all listed as 502. But ever since the network came back online they're showing as 1. The sector ID has also changed. Wonder why / what they're even doing?

I dont know if its a fluke but yesterday and just before the cells went down today...  I was doing speedtests   and consistently hitting 100+ around now and up until 4/5pm every day.  Now the highest I've gotten is ranging 50-60 Mbps . I hope they haven't made some kind of changes that affects the triple ca  Huh  Felt like something similar happened when I first got the router. Was getting 100+ speeds then they did some kind of changes and it became useless again. Speedtests all before that first 100Mbps test  were all 100+. Before todays "works" I was getting 50+ on each band individually so I would't be surprised something changed now that I can't even reach that speed aggregating 3 cells.

Edit: To make things more frustrating, it appears like some kind of traffic shaping was added , vultr is no longer prioritized and I was getting exactly 10-11 Mbps and it would not go past it on the test file downloads while speedtest.net was getting 50-60. Something definitely changed... idk what exactly. It behaved the same way on the dungloe cell which had traffic shaping... Why would they decide to make the network worse when it was fine as it is? Or what do they even gain from traffic shaping.


I discovered that battle.net servers are also prioritized by three for some reason... My Call of Duty Warzone update download at almost 20 MB/s when I could barely get 50 mbps in ooklas speedtests... So to get past this I use SSTP/OpenVPN protocol on a specific vpn server using hide me? I guess they have just added traffic shaping as of today. You can see below

[Image: YreSPKM.png]


[Image: HybG34b.png]


Cell ID's after initial upgrade: 
[Image: XqhCoM1.png]



Cell ID's after coming back online: 
[Image: eNlv2cI.png]
I reckon Three took the Dutch Vultr host out of what gets priority due to all the tests we've been doing to that host.  Remember what happened with WARP+... Big Grin  The other three European hosts still get priority from a quick test on all four here:

   

Although the cell IDs have not changed here, the speed has dropped well back compared to yesterday.  Those above tests were run at 4pm and usually it's well over 100Mbps before 6pm with the distant 4G+ site I pick up.  It even dropped my connection altogether just after the last test, requiring me to restart the router to get back online. 

I will do some packet loss tests later this evening.  Hopefully this storm is not the culprit - If the microwave antennae are blown off alignment, who knows when the engineers will be out again.  Back when we had a 1.6m satellite dish, it felt like  the weather was deliberately teasing us.  Every time I had that dish finally tuned, a major storm would come a few days later to blow it off alignment!  Cry

I updated my traffic shaping test thread to mention to use the UK Vultr server instead. 

For the Hide Me VPN, I usually use the Irish server as this avoids causing issues when checking my e-mail, etc.  For example, if I select France, I'll end up with security warning e-mails from various providers saying my account was accessed in France.

Update 520pm: From a quick check with the Hide Me VPN Irish server, it still seems to be fine at the moment.

TestMy UK London direct vs over Hide Me VPN (OpenVPN TCP protocol):
[Image: 4Sw_D38Fh.png] [Image: 8jL3O7uZa.png]

As the Hide Me VPN runs over a single thread with the OpenVPN TCP protocol, you'll probably notice that most speed tests give similar results. E.g. Ookla's speed test doesn't gain any advantage trying to make lots of simultaneous connections to its test server as they are all piped over the single connection to the VPN server.

I still find it surprising the speed I get from the TestMy Colorado Springs test site:
[Image: 8jXZ9Tbs~.png]

I suspect Three uses TestMy for its own testing as occasionally the server that gets prioritised changes. For example, up until a few months ago, the Los Angeles server was prioritised and the Colorado Springs one was not. I occasionally test every one. Tongue
I will try do some testing later tonight to see what I can get out of it, and what works. The speed was there until whatever they changed yesterday. I dont understand why they would change the cell ID's and then right after that, speeds all deteriorate because of what looks like newly added traffic shaping. 

Do you think that lightning or wind today could've caused anything? Or do you think they did just add some new traffic shaping as of today? 
I can't see the colorado server anymore for some reason. Am I blind? Big Grin
It wouldn't surprise with Three.  Hopefully it's just temporary, especially with it coinciding with the storm. 

The Colorado Springs server is the second one down the list.  If it's not there, you can try refreshing the page as they probably remove servers temporarily when the load is high.

   

Speaking of eye sight, I've just had cataract removal surgery with my second eye. I'm only 38. It came on very quickly last year with my left eye vision like looking out a fogged up window.   On the positive side, I'm glasses free now as I was extremely near-sighted beforehand.
I figured out why it wasn't showing up , I had to be signed in Big Grin Speeds are extremely good to the colorado one at all times. I dont understand why they limit traffic speeds in the first place/ prioritize certain services. Is it just for the purpose of balancing the bandwidth amongst every user? or what is the actual reasoning behind it?

And for the masts themselves , why dont they just supply a lot of fiber connections /more bandwidth to them so theres plenty to go around for everyone who's forced to use mobile broadband like we are. Is it a saving money thing or is it just not realistic to do that?
I really hope they extend the band 1 spectrum licence at least because it's very good for gaming on. I swapped one of the ports around with the LOG's and it improved my 3G band 1 signal from -93 RSCP to -73 RSCP. Do you think maybe one of them really is faulty? They're both mounted at 45 degrees aiming at the same direction. One has much worse signal than the other. Seemed to always be that way.
I didn't notice that until I checked here. I might ask them in case as I don't think they intentionally restrict any server to members. (Edit: Colorado Springs server does require logging in)

My best guess is that Three prioritises the main services people use, such as YouTube, Google Docs, Cloudflare and so on, so that when contention occurs, it affects other types of traffic first, such as file downloads from less common sources, unofficial IPTV services and so on. I still remember when Ookla's speed tests got priority, but that stopped when I posted about this a few years ago. At that time their service was so slow here that most websites took at least 10 seconds to load each page despite Ookla's speed tests showing 20+Mbps speed tests (vs <1Mbps on TestMy), whereas my 5Mbps DSL connection at the time could load webpages in 1 to 2 seconds despite only getting 4Mbps on both speed test sites.

Indeed cost is the big issue with running fibre to the masts. It would be like getting a leased fibre line right to your house. Besides the installation cost, I'm sure it would be cheaper to rent a house in Dublin than what the leased fibre line would cost. Microwave back haul on the other hand has no such cost apart from paying for the licenced spectrum off ComReg, but unfortunately doesn't have the bandwidth that fibre can deliver, usually just a few hundred Mbps. Most rural masts also form part of a mesh network with other masts, so you connection could be carried over several microwave links before it reaches a mast with fibre backhaul.

As 3G operates does not use circular polarisation like 4G does, you would need to compare the RSRP between the two in 4G mode. 3G can operate in vertical or horizontal polarity. If the mast is using a single 45 degree antenna to achieve this on 3G (e.g. using one of their 4G antennas to also carry 3G), then both vertical and horizontal polarisation will pick up the 3G signal with about a 3dB loss. However, an antenna cross-polarised to the opposite 45 degree angle would technically reject most of the signal. Smile
I noticed Three made some big improvements in parts of Letterkenny, particularly around the LYIT and shopping centre area.  A few months ago, the speed was so poor in the Tesco car park that speed tests were in the low single digits, like <2Mbps.  Today, I've had the highest 4G speeds to date on my phone with both Ookla and TestMy London:

[Image: 6438378725.png] [Image: rfteI~sEB.P1L-tXsNQ.png]

That was with band 3+3.  Three were using band 1 there also, however, my phone doesn't support 3+3+1 CA.  As three didn't appear to be any traffic shaping there (TestMy Colorado Springs server was slower), a band 3+3+1 CA capable phone probably would have tested around 300Mbps.  

At my brother's house, I was picking up 4G+ with bands 28 + 1.  I didn't pick up band 28 there a few weeks ago (just band 1), so it's a good sign that the temporary spectrum will get extended.  

   
Wow 200 + Big Grin what are they even doing to make it so much faster? Is it the new bands or is it new equipment as well. Its nice that they've started to upgrade everything, Ill keep an eye out to see if band 28 becomes available too.
I gave Twitch a quick test run over my Three connection and over the Hide Me VPN to see how each copes.  As I haven't used Twitch before, I just picked a random video on the homepage, in this case something Minecraft related.  I don't play games, so was unsure what to try, but I do know my nephews like Minecraft. Smile

Anyway, unlike YouTube, Twitch clearly does not get prioritised as the auto resolution settled on 480p.  When I forced it to 720p, it would intermittently buffer and sometimes play fine for a minute or two.  1080p was unwatchable, constantly buffering.

Over the Hide Me VPN, it seemed to have no issue streaming 1080p and the buffer held steady over 2 seconds.  The Chrome browser kept skipping frames at 1080p 60Hz, likely due to my PC's on-board graphics.  

Video stats - Direct on the left, over Hide Me on the right:

       


Forum Jump:


Users browsing this thread: 2 Guest(s)