Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mikrotik Chateau 5G / Unable to hold N3/N78 bands RG502Q-EA
#1
Trying to figure out an issue with 5G where I live, I live about 16 kilometers away from the serving mast from Three Ireland with direct line of sight.

I have a netgear MR5200 + Mikrotik chateau 5G , and a samsung S20 + A52 5G and they all cannot connect to the 5G from home. The *#0011# SIM information readout on my S20 says : RACH_PROBLEM and the 5G symbol keeps flickering from outlined grey to white over and over.

I initially thought in the past the 5G symbol flickering from outlined 5G to full white was something to do with N78 band being unable to synchronise the uplink since I am 16km away like Seán has said in the past. Three Ireland upgraded the site and deployed N3 here so I thought I should have no problem getting that but the same issue occurs.

Regardless of where I select N3 only on the mikrotik 5G router or not. However the A22 5G has no problem getting 500 Mbps down and about 60-70 Mbps upload and it connects to both N78 and N3.One thing to note is my S20 connects to N78 and N3 on every other site I’ve been to while travelling and also when I drive closer to my serving cell. It just seems to be unable to from home. I assume the routers would be able to as well.


It will just keep failing to connect every few seconds… on the chateau 5G it is something similar. It will show N3 for a second or two then disappear and all the bands will aggregate differently. It will keep doing this in a loop every few seconds and will not hold onto the N3 connection. There is more than adequate signal.
I manage to catch a screenshot of when it briefly connected before losing it.


[Image: dc6ac3c9227823481f8d82d62d612c3adadaf5e1_2_690x238.png]

[url=https://forums.quectel.com/uploads/default/original/2X/d/dc6ac3c9227823481f8d82d62d612c3adadaf5e1.png][/url]


I then tested my partners A22 5G phone connects no problem though with really good speed results, on both N78 and N3. I was really surprised about being able to connect to N78 since I am 16 km away.
The common thing between my devices is they all have a snapdragon X55 modem. and the A22 5G has a Mediatek Dimensity 700.
Why is the mediatek able to connect no problem whereas my other 4 devices all have this same issue. Is there a way to rectify this ? 

Reposting it as a more condensed summary of the issue Tongue  so I can link it to Three. I've posted on quectel also to see if they have any opinion
Reply
#2
I received this reply from quectel , wondering how you would reply to this and wonder what you think he means by QXDM log Big Grin

I'm not home atm so I'm unable to test these yet

"Dear sir
Thanks for your asking.
I guess you are using a CPE device that embedded our nr5G module, right? which module do you use? you could use ati command to get the information.
Do you mean your device(X55) can not register n78 SA but the other device(MTK 700) can register n78 when you are 16km away the base station?
If yes, please help to get the returning results of at+cgatt?/at+cops?/at+qeng=“servingcell”, and help to provide the QXDM log to us also.
By the way, it will be better to ask the question from the CPE device company.
Thanks!"
Reply
#3
QXDM is a specialist professional diagnostic tool, which is intended for lab use.  This is not a tool that you'll be able to use or probably afford given that Qualcomm says to contact them for pricing.  Back when I contacted MikroTik support with the issue I had with the Chateau LTE12 getting stuck trying to connect to out of range cells, they ran a log on my router, but have no idea what tool they used, possibly their own diagnostics.  

Quote:Do you mean your device(X55) can not register n78 SA but the other device(MTK 700) can register n78 when you are 16km away the base station?
You can mention that the X55 devices get stuck in an endless loop trying to register n78 NSA.  The MTK 700 device registers successfully with n78 NSA, both at the same location 16km from the base station.

Quote:If yes, please help to get the returning results of at+cgatt?/at+cops?/at+qeng=“servingcell”, and help to provide the QXDM log to us also.
With 5G enabled and trying to connect to n78, run the following commands on your Chateau 5G:

/interface lte at-chat lte1 input="at+cgatt?"

/interface lte at-chat lte1 input="at+cops?"

/interface lte at-chat lte1 input="at+qeng=\"servingcell\""

Copy & paste the results or take a screenshot.

An alternative log to QXDM would be to provide the modem diagnostic log. 

First, run the following command to enable logging of the modem:

/system logging add topics=lte

Wait until you see the n78 cell appear and disappear in the LTE status page.

Run the following two commands, the first is to disable modem logging before displaying it:

/system logging remove [find topics="lte"]

/log  print

Copy & paste the logged content back to them, redacting any IMEI, phone number or other personal info that may be present.
Reply
#4
Thanks for that, replied to them there hopefully something is done about it. I posted the update with what you said to do on mikrotiks forum too but no one replying Big Grin 
I got a reply there but you can see what you think of that, I thought the signal was enough. 

I noticed for the first time ever 5CA being used, would be amazing if this would actually connect, I'd say it'd be really fast. I really hope it is fixable, doesn't make much sense as to why they can't work.  I wonder if mikrotik will create a 5G LHG device with a different modem, that would be incredibly good.

Post is here https://forum.mikrotik.com/viewtopic.php?t=181717

[Image: ARZOpaN.jpg]


Did some speedtests on the road down towards the hospital from the mountain top in letterkenny.  Quite good speed results Tongue 


[Image: seDOM2c.jpeg]
Reply
#5
Got this reply from mikrotik, I assume he means try getting the N3 disconnect loop then go LTE only?
Even more frustrating is the fact the mast has blown off alignment again with the wind, signal is all bad again, how is this even happening every time there's wind. I don't think it's water because the vertical 3G antenna and vertical LPDA are ok but the 45 degree and horizontal polarisations are extra weak.

Please enable lte debug logging and send us the supout.rif file from your device after you have rebooted it and encountered the issue.

LTE debug logging can be enabled from CLI by issuing this command:
/system logging add topics=lte

This article explains how to make a supout.rif file:
https://wiki.mikrotik.com/wiki/Manual:Su...utput_File

Would be ideal if supout file would capture the moment where the modem was connected to N3 band and then is reconfigured to LTE only.

Regards
Reply
#6
That's appears to be what they're looking for, i.e. enable the 5G n3 band, wait until the n3 band connects/disconnects, then create the support.rif file. Repeat this process with just LTE enabled.

The recent gusts across Co. Donegal were much stronger than storm Barra despite Met only giving a marine gale warning. I heard it snapped a few people's TV antenna poles in Letterkenny and caused several thousand more power outages further north than from storm Barra. It blew our satellite dish off alignment, which last happened several years ago. So I wouldn't be surprised if it moved your antennas a bit. Horizontal is more sensitive than vertical to alignment. For -/+45 degrees, one will also dip before the other as one antenna will be in the shadow of the other as they move off alignment.
Reply
#7
My LPDA's are fine and in the right spot so do you think it's the mast that is affected now? typical the day I'm sending the supout file I cant get it to show N3 cuz its weaker
Reply
#8
Quectel being kind of useless here: 

About your issue, we need QXDM log or qlog to check more. Please ask your device manufacturer to assist you.At the same time, please help to reply below questions, so we can ask related colleagues to help you too.Thanks!
  • Company name and located city:
  • Project name (so we can refer to it in the future):
  • Application type:
  • Estimated Annual Units (for series production):
  • Project timeline:
  • Current status:
  • From which distributor do you buy Quectel modules & EVB kits &?
Reply
#9
It's worth try swapping the extension from a good antenna with one of the weaker ones. If the strong and weak signals remain the same, this will rule out the extensions having water ingress. I'm just surprised that only one polarity degraded on each MIMO.

Quectel appears to assume you are an enterprise or distributor of MikroTik products. It looks like they want you to raise this issue with MikroTik support instead of with them. This is what happened when I tried contacting Quectel with the issue I had with the Chateau LTE12 modem getting stuck trying to connect to out of range cells.
Reply
#10
It's already fixed, I complained to three she answered at 9 am , working now, wonder did they fix it that fast or was it just water ? 

I got an answer from mikrotik but unsure how to let them remote in 

Hello,
From the log I can see that the modem is constantly reporting packet service connection to 5G NSA data class, but it is reporting that multiple times every second:
15:50:44 lte,debug lte1 mbim: packet service: attached class: 40 new:

Could you try to lock the lte band to 1 and 3 and check if the issue is the same then? Please attach a new log with this set.
/interface lte set 0 band=1,3

This is some weird behavior that we have not seen before. Would it be possible for us to get remote access to your device? If yes, then we will need to reboot it a few times. Also please provide access from the Ethernet side, we would be connecting from network [ip address they sent here + port]  We would need SSH/Winbox access and we will need to connect to the router's specific TCP port (TCP port 9000) as we will need to upload a debug tool.
Regards,
Reply
#11
To provide them remote access, you will need to use another router (e.g. LHG dish) to provide remote access to the Chateau 5G.  It will need a public IP address, e.g. if the 3internet APN provides one, that should work fine.  You will also need a Three SIM in the Chateau 5G, although this one doesn't need a public IP address, so a Three phone SIM will be fine.

First, change your Chateau 5G password to something that you can provide MikroTik.  As you will need to provide remote access temporarily, it should be something secure like a mixture of letters and numbers.  i.e. go into System menu -> Password. 

The following is a rough guide to try with providing remote access from the LHG:

  1. Set up a LHG dish for Internet access, using the 3internet APN.
  2. Go into the IP menu -> Addresses.
  3. Check the IP address shown on the column that starts with 'D'.  If it starts with 10.x.x.x or 100.x.x.x, then it's a private and port forwarding will not work.
  4. Double-click the line with '192.168.88.1/254'.  Change it to '192.168.88.5/24', then click 'OK'.
  5. Reconnect to the LHG with this IP address 192.168.88.5.
  6. Go into the IP menu -> Firewall, then go into the NAT tab.
  7. Click '+' to add a new entry, then go into the General tab.
  8. For Chain, choose 'dstnat'.
  9. For protocol, choose TCP
  10. For DST. Port, enter: 22
  11. For 'In. Interface', choose 'LTE1'.
  12. Go into the Action tab.
  13. For 'Action', choose 'dst-nat'
  14. For 'To Addresses', enter '192.168.88.1'
  15. For 'To Ports', enter: 22
  16. Click 'OK'.
  17. Repeat steps 7-16, but enter 8291 for steps 10 and 15.
  18. Repeat steps 7-16, but enter 9000 for steps 10 and 15.
  19. Go into the IP menu -> Cloud.
  20. Tick "DDNS Enabled", then click 'Apply'.
  21. When the DNS Name field appears, copy & paste it somewhere handy.
  22. Go into the IP menu -> DHCP Server, then into the DHCP tab.
  23. Click the deconf line, then click the red 'X' to disable DHCP'.
  24. Connect the Ethernet cable from your Chateau 5G to the LHG.

If all goes well, you should able to connect to the Chateau 5G Winbox from your phone over its 4G connection using the DNS name from step 21.  If this works, you can respond to MikroTik support mentioning you are set up, mentioning the DDNS address from step 21 and the Winbox username and password for the Chateau 5G.  

From my past experience contacting MikroTik, they took 1 to 2 days before they did their remote access diagnostics, so you'll need to leave this enabled until they respond that they no longer need access.

Once they are finished, you can re-enable the DHCP on the LHG, change its IP address back to 192.168.88.1 (steps 2 & 4) and remove the three dst-nat entries from the Firewall's NAT tab.
Reply
#12
I topped up the LHG by 20 euro and the ip is a 10.x.x.x. in that menu, does that mean it wont work? Cry , when I look up what my ip is online ,it's 80.x.x.x.x

upgraded it to ROS 7.1 as well and it seems to have caused issues as the internet wont work now either Big Grin bit of a mess up , not sure how to rectify

I managed to downgrade it to 6.49 through winbox, fixed that problem at least, but the issue now is I wonder if the IP will work
Reply
#13
It's possible there is some configuration not compatible with the new RouterOS version, especially if you upgraded from version 6 (which the LHG originally had). I suggest try doing a factory reset on the LHG, which you can do by going into System -> Reset Configuration. Once you are online, go into Interfaces -> LTE tab -> LTE APNs button, then double-click the 3internet APN. Clear the "Use network APN" checkbox and click OK.

If its IP address still remains 10.x.x.x, check what IP address you have on the Chateau 5G. If it is public IP address, you can try swapping the SIMs temporarily. I still get a public IP address on Three, which is a bill pay broadband SIM. I no longer have a Three phone SIM to check if the 3internet APN still gives a public IP address, but have heard that this no longer works with new prepay phone SIMs.

If both your routers have a 10.x.x.x IP address, then unfortunately the port forwarding will not work. In this case you can mention this problem to MikroTik support to see if they have another suggestion.
Reply
#14
Both seem to show that 10.xxx IP range in the address section , with 3internet also. Is there any way to test if port forwarding will work before doing all the config? I have a 48 sim but I also guess that will have a private IP too? I could use my eir 5g sim either.
Reply
#15
Unfortunately, port forwarding will definitely not work with a 10.x.x.x or 100.x.x.x IP address as there is no way to set up port forwarding within the ISP to forward the public facing IP address to the 10.x.x.x address you are assigned.  In fact, your public facing IP address is likely shared across many other Three customers, in much the same way your router shares its WAN IP address with all the devices on your home network using NAT to assign 192.168.x.x addresses to them.  

Three is the only network that I'm aware of that was still issuing public IP addresses, but it's looking more like they have limited them to its bill pay broadband SIMs.  Both Vodafone and Eir only issue private IP addresses, even with their bill pay broadband SIMs.  For example, my Eir phone SIM has a 100.x.x.x IP address and my 48 SIM has a 10.x.x.x IP address. 

Just to double-check the APN settings, these are the screenshots of the APN configuration from my Chateau 5G to compare against:

       
Reply
#16
Wait actually doing that through winbox I got a different IP now, it's showing 178. something , is that right? I re connected on different bands and its 89.xx now too , so its no longer only 10.xxx
Reply
#17
That seems like a public IP address. Smile

You can double-check by doing a Google "my ip address" to see if it matches what Google reports. If it does, then port forwarding should work.
Reply
#18
This worked on the chateau but I don't have the option of unselecting use network apn , so I haven't been able to get it to work on the LHG yet Cry
Reply
#19
I think the LHG only uses a manual APN, but can't remember for sure, so it's possible its Three SIM is one affected that can no longer get a public IP.

You can try the following from the terminal to see if the use-network-apn works from there:

First type:
/interface lte apn print

Take note of the line # with the 3internet APN, then enter (replace 0 with this line #):
/interface lte apn set 0 use-network-apn=no
Reply
#20
The second command doesn't seem to work for some reason, it is a blank sim so it's probably ex o2 one or something? maybe thats why it doesn't work Cry It has roaming box checked and greyed out on the LHG 4 , unable to check or uncheck roaming.

Command is valid up until set, then it was black text, when I did /interface lte apn set  it gave me an option of "numbers":  and I typed 1 , which was the right one , but still private IP range.

Copying your LTE APN settings seemed to give me a public IP on the chateau though everytime now, whereas before it was always a 10.xxx 
Wonder if it's the "Use network apn" setting that causes it, because I had 3internet typed into my apn box before but it was still private until I did this stuff in winbox.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)