Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mikrotik Router Setup
#1
Hi Folks
Newbie here some great information on this site. Just received the MikroTik LTE12 router just trying to set it up. Is there any guides anywhere for a quick setup. Apologies if there is something in the posts.
Thanks John
Reply
#2
To configure the router, you can either use the web interface (192.168.88.1) or the Winbox application. With Winbox, put in 192.168.88.1 for the "Connect to" field, "admin" for the username and a blank password.
https://mikrotik.com/download

Go into the Quick Set tab (top-left icon in Winbox).

At the top-right of the screen in the web interface (top-left in Winbox), choose "LTE AP Dual".

Fill out the following fields:
  • Country - Choose your country.
  • WiFi Password - Don't leave it blank! This will be the password for connecting Wi-Fi devices.
  • PIN - SIM card pin, leave blank if the SIM doesn't have a pin.
  • APN - Network APN. For Irish networks, see this page. If you can't find the APN for your network, try leaving it as "internet".
  • If you have external 4G antennas attached, change the antenna setting to "External both".

Click OK and check for connectivity.

To access the LTE configuration or check signal readings, go into the Interfaces menu, double-click on 'lte1'. The General tab lets you set the network mode, APN, bands, etc. and the Cellular tab shows the signal readings.

To set a password to access the router's configuration, go into the System menu -> Password.
Reply
#3
Thanks Sean that's perfect one slight problem I seem to have screwed things up cant connect to router by any of the ways you suggested. Tried the holding reset button etc but can't connect. Do you think I would need to go down the Netinstall route seems a bit complicated. This router is certainly not a plug and play setup.?
Reply
#4
I think you may have put it in bridge mode. The Quick Set drop top down is set to by default from what I recall.

You can try connecting by MAC address using Winbox. Connect the computer directly to the router with an Ethernet cable. In the Winbox logon page, click the Neighbors tab, then click Refresh to see if it lists the router.

From what I recall doing a hard reset, the reset button needs to be held in for 5 seconds upon applying power until one of the front LEDs starts blinking. If it's held in too long, it goes into looking for a CAPsMAN or Netinstall server, but don't think it clears its configuration.

If the mobile network uses "internet" as its APN and there is no pin on the SIM, the router should automatically connect to 4G with the default configuration. However, its Wi-Fi network will be open, i.e. anyone can connect without a password.
Reply
#5
Hi Sean very much appreciate the advice I am up and running with the router. I am currently getting good speeds 70-90mbps off-peak and 30-40mbps on a mobile phone. I had an old E5186 router an Xpol2 panel directional antenna. I am pretty sure the good speed on the mobile phone is from a band 20 mast in Fanad.I am approx 17km from the mast with a small hill the only thing stopping direct line of site. I have now the directional antenna attached to mikrotik router but only getting 2-5mbps. Am I missing the signal with the directional antenna would I need an omni to catch signal.
Reply
#6
Hi Folks
Can anyone verify where this mast is based on the attachment speed was 58mbps t 6.15pm Sunday evening. This was on an iPhone xr.
   
Reply
#7
Your phone screenshot shows BW 10+20, which means it's connecting to two bands, likely band 3.

Check the signal readings in Winbox - Go into Interfaces, double-click the 'lte1' line, then go into the Cellular tab. Check what it shows for the Primay Band and CA band. The B20 "phy-cellid" should match the PCI value above if it's connecting to the same mast. The RSRP is the signal strength. If the panel antenna is aimed correctly, I reckon it should be 10-20dB stronger than your phone, i.e. -101dBm to -91dBm. The TA (timing advance) in the above screenshot is a rough indication of how far you are from the mast, i.e. ~26.4km.

If the signal is weak, check that the router is set to use the external antennas. I think this setting is in the Winbox menu: System -> RouterBoard -> Settings.

There's no benefit to switching to an omni antenna. If anything, it will make the signal worse as these are mainly intended for use in moderate to strong signal areas.
Reply
#8
Hi Sean I am slowly but surely getting the hang of the setting etc on the router thanks to your advice much appreciated. I can get the RSRP to -89dBm on band 20, when I introduce band 3 I lose all sight of any signal. Is CA automatic or do I need to force these. The only CA that seems to work is band 1 and 28 and nothing works when I check the box for band 3.
Reply
#9
It looks like you are outside the maximum range limit for connecting band 3 as the primary band. The Chateau LTE12 modem has an issue where it endlessly tries connecting on band 3 as ther primary if the signal is strong enough, the same issue I had with my Chateau LTE12.

Try enabling band 3 again, then type the following in the Winbox terminal (click New Terminal in the left menu):
/interface lte at-chat lte1 input="at+qnwlock=\"common/4g\",1,6400,11"

This will force it to use the cell ID 11 on EARCN 6400 (band 20) as the primary band. It should connect to band #3 as the secondary band.

If this does not work, you can remove the cell lock by either rebooting the router or typing the following command:
/interface lte at-chat lte1 input="at+qnwlock=\"common/4g\",0"

The cell lock lasts until the router is rebooted or loses power. To make it run each time the router reboots, go into the menu: System -> Scheduler, click '+', click the drop-down next to "Start time:" and choose "Startup", then copy & paste the following into the "On event" field and click 'OK':
Code:
delay 30
/interface lte at-chat lte1 input="at+qnwlock=\"common/4g\",1,6400,11"

This way when the router reboots or after a power cut, it will run the cell lock command automatically after 30 seconds, by which time the modem will have initialised.
Reply
#10
Hi Sean as usual your advice is spot on now have band 20 primary with band 3 CA. Getting approx 20-30 dBm but just tried phone and still getting around 50dBm. Is it a case of directional antenna not picking up the same band 3 as the phone. Will the Mikrotik only use 2 bands would it not use 3g as well. I have attached screenshot of setup.
Thanks John


Attached Files Image(s)
   
Reply
#11
The signal strength (RSRP) in the screenshot is a lot better than what your phone was showing. A less negative figure is better, i.e. -87dBm is better than -111dBm. The SINR value is a little low, so it's possible it is not aimed directly at the mast or picking up mild interference from another mast.

To check the band 3 reading, type the following command:
/interface lte cell-monitor lte1

Look for the line that shows B3, phy-cellid 243. The RSRP reading on that line is your band 3 reading. It doesn't show SINR for the aggregated bands.

I'm not aware of any router capable of aggregating 3G with 4G. If you mean a third carrier, it's possible Vodafone only has that mast configured for band 20+3 carrier aggregation or that the band 1 and 28 you picked up are served by a different mast.

If the outdoor antenna is easy to get at, you can try turning it 10-20 degrees in each direction to see if you get the RSRP reading for that band 3 cell any better. You can run that cell monitor command on your phone in the MikroTik App -> Menu -> New Terminal.

Unfortunately, Vodafone does apply traffic shaping on their network between different types of SIM cards. For example, the Vodafone X prepay SIM is usually capped at 10Mbps with brief bursts above this. I have also heard in the past of them capping broadband SIMs.
Reply
#12
Hi Sean
Been trying to get the best signal on band 3 manged to get -98 RSRP.  This hasn't improved the speed much if any. Is it a case that carrier aggregation is better on my S20 ultra mobile than the Mikrotik router. Or could there be something wrong with the directional antenna. Just getting unreal speeds on the phone for this time of the evening as shown below. Should I keep trying or find a way to harness the phone as my router.
Thanks as always John


Attached Files Image(s)
       
Reply
#13
Going by the signal strengths, your antenna is working fine. Could you post a screenshot of the cell-monitor or mention the RSRP and RSRQ readings it gives for each B3 cell.

This is still possibly Vodafone doing different traffic shaping for modems and routers than with handsets. Before Vodafone left Boards.ie, there was a long thread in there of people complaining about getting much faster speeds on their handset than with Vodafone's mobile boardband.

If you are using a different Vodafone SIM in the router than what's in your phone, I suggest trying your phone's SIM in the router. Just be sure to set the APN first - In Winbox, go into Interfaces -> LTE tab -> LTE APNs button. Double-click the default item and set the APN field to the APN your phone uses.
Reply
#14
Hi Sean,
The sim is a phone not a data sim.apn set as live.vodafone.ie
Please see cell monitor data


Attached Files Image(s)
       
Reply
#15
Your B3 reading is good and plenty of headroom from the next neighbouring cell #6, so it appears your antenna is fine and not picking up interference on that high capacity cell.

One more APN setting you can try - In Winbox go into Interfaces -> LTE tab -> LTE APNs button. Double-click on on the default item and clear the box for "Use Network APN".

With speed test, check that you are using the same speed test server with both both your phone and router, e.g. Blacknight. You can also try a different speed test such as fast.com or Google's speed test by typing "speed test" into Google and click the blue "Run speed test" button.


Routing the MikroTik connection through your phone

If you would like to try running your Internet connection through your phone, you can either set up your phone as a Wi-Fi hotspot or as a USB modem for the MikroTik router to route its connection over. I'll explain how to do this via your MikroTik router as this will keep your phone powered at the same time.

To start with, you will need to change a setting in your phone's APN profile if you haven't done so in the past. This is especially important with Vodafone prepay, otherwise Vodafone charges for hotspot/tethering as out-of-bundle usage.

With your Samsung phone, go into your phone's Settings - > Connections -> Mobile networks -> Access Point Names. Touch the live.vodafone.com entry. Touch the APN type field. Add ",DUN" to the end (unless it is already in there). For example, if it shows "default,supl", this would become "default,supl,DUN". Touch 'OK'.

Connect your phone to the MikroTik's USB port.

Swipe-down twice from the top of your phone, then touch the Android System USB item. Touch "USB tethering".

Go into Winbox, then into the Interface List tab. Click the '+' icon. In the List drop-down, choose WAN. In the Interface drop-down, choose lte2, then click OK.

Finally, go into the Interface tab, then click on the lte1 entry to highlight it and click the red 'X' to disable the built-in modem.

Your Internet connection should run over the phone until until you disconnect the USB lead. While the lead will unlikely provide enough power to rapidly charge your phone, it should be sufficient to prevent its battery draining.

When you are finished, go back into Winbox -> Interfaces -> Interface tab. Click on the lte1 entry to highlight it, then click the blue tick to re-enable it.
Reply
#16
Hi Sean,
Your instructions as always are fantastic. I have connected the phone to the router and I'm getting great results. One slight problem when I sometimes connect phone the USB tethering sw sometimes is greyed out takes ages to sort any ideas why
Couple of questions I'm thinking about.
Could I combine the phone tethered broadband and my Beacon Broadband into the Mikrotik Router?
Seen the post about Tenga mesh would this work OK with the above scenario?
Thanks John
Reply
#17
From further testing with my MikroTik, it appears that the USB port needs to be reset after unplugging the phone for it to recognise it again. I'm not sure if this is just a firmware bug, however, one workaround is to have a script automatically reset the USB port.

To manually reset the USB port:
  1. Unplug your phone from the USB port.
  2. In Winbox, go into System -> RouterBOARD.
  3. Click "USB Power Reset".
  4. Chose '2' for the Bus drop-down, then click USB Power Reset.
  5. Wait at least 10 seconds, then plug your phone back in.
  6. Enable USB Tethering on your phone.

The workaround below will have the router automatically disable the built-in modem LTE1 when the phone is plugged in. When the phone is unplugged, it will re-enable LTE1 and reset the USB port to have ready for when the phone is later plugged back in.

  1. In Winbox, go into System -> Scheduler.
  2. Click the blue '+' in the toolbar.
  3. In the Name field, type: LTESwitch
  4. In the Start Time drop-down, choose 'startup'.
  5. In the Interval field, type: 00:00:10
  6. Copy & paste the code below into the "On Event:" field:
    Code:
    local LTEPCount $LTECount
    global LTECount [len [/interface lte find]]

    if ($LTECount = 1 and $LTEPCount = 2) do={
        /interface lte enable lte1
        /system routerboard usb power-reset bus=2
    }

    if ($LTECount = 2 and $LTEPCount < 2) do={ /interface lte disable lte1 }

You should see the USB Tethering option on the phone when plugging the phone in. As the interval is 10 seconds, give it at least 10 seconds after connecting/disconnecting the phone to switch over. If the script appears to do nothing or the USB tethering remains greyed out, unplug the phone and reset the USB port one more time.

Unfortunately, I have had no luck with aggregating two different Internet connections successfully, at least not with LTE. To combine the bandwidth involves a load balancing VPN and any I've tried just delivered no better than one of the Internet connections, in addition to the latency and cost of running the VPN connection. The other option would be to have one as a fail-over connection, such that when the phone is plugged in, it becomes the primary connection and when unplugged, the connection automatically returns to the Beacon Broadband connection.

You can use a Tenda Mesh with the MikroTik, i.e. connect the Internet/WAN port of the primary Mesh node to any LAN port of the MikroTik, then follow the instructions with the Tenda to set it up. Afterwards, you can connect your Wi-FI devices to the Tenda nodes, then disable the MikroTik's built-in Wi-Fi .
Reply
#18
Hi Sean
Thanks for all the advice as usual. Is there any resources you can recommend regarding all this coding for the Mikrotik router. I want to take your advice about connecting the beacon broadband to the Mikrotik and then using the good signal on the phone as the failover as I want. I am sure the coding for all that wouldn't be easy and I fell like you have already given me plenty of great advice and coding that has worked perfect so don't want to be always asking or taking up your time. 
Thanks John
Reply
#19
I learned the MikroTik scripting mostly from their documentation and the example scripts, including some I came across on their forum. The following is their main documentation page on scripting:
https://wiki.mikrotik.com/wiki/Manual:Scripting

I missed a step above on setting the LTESwitch to automatically run on start-up, otherwise the script will stop working the next time you reboot the router. I revised the above post, but here the step to perform:
  1. In Winbox, go into System -> Scheduler.
  2. Double-click the LTESwitch line (added earlier from the above post).
  3. In the Start Time drop-down, choose 'startup' then click 'OK'.

The following guide will configure your router to route the Internet connection over Ethernet port #5, which you can plug your Beacon broadband into:
  1. In Winbox, go into the Bridge menu, then into the Ports tab.
  2. Click on the 'ether5' line, then click the red '-' icon to remove it.
  3. Go into the IP menu, then into DHCP Client.
  4. Click the blue '+' icon.
  5. In the Interface drop down, choose 'ether5'.
  6. Go into the 'Advanced' tab.
  7. Change the Default Route Distance to either '1' to give this port priority or '3' to have it act as the default, then click 'OK'.
  8. Go into the Interfaces menu, then into the Interface list tab.
  9. Click the blue '+'.
  10. Choose 'WAN' for the List drop-down and 'ether5' for the 'Interface' drop-down, then click 'OK.

I suggest choosing '3' for step #7 to give the LTE connection priority. This way when you plug your phone in, the Internet connection automatically switches to the phone. When you unplug the phone, the Internet connection returns to Beacon broadband on port #5 or the built-in LTE modem if a SIM is present. If you disable the built-in LTE interface or the LTE connection goes completely down (e.g. mast goes down), it will also switch automatically to the Beacon broadband.

If you chose '1' for step #7, the Internet connection will always divert to Ethernet port #5 as long as that cable is attached and your beacon router is powered on. A drawback here is that if the Beacon broadband goes down, the router will likely continue trying to route over the Ethernet port 5 as long as it remains plugged in. This Ethernet cable needs to be unplugged (or disable port #5) for the Internet to divert to the LTE connection. However, if you choose this method, this would be a good opportunity to try writing a failover script to switch to LTE if there is no ping reply on port #5. Smile
Reply
#20
Hi Sean,
Seem to have hit a slight stumbling block as error in photo shows. On the bridge bit have I removed one to many.


Attached Files Image(s)
   
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)