Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Setting up the TP-Link Archer MR600 with GoMo / Eir simplicity
#1
The TP-Link 4G routers are popular alternatives to the Huawei mobile broadband routers, mainly due to their low cost.

While they are preconfigured to work with most mobile broadband SIMs, this configuration will not work with many voice SIMs as most mobile providers use a different APN for voice SIMs.  With GoMo and Eir simplicity, their 4G network requires the correct APN and the SIM PIN set.

If you have an unlocked mobile phone handy, I recommend putting the SIM card into it to remove the SIM PIN (Andriod Settings -> Security -> Advanced -> SIM Card lock), then make sure the SIM's data works fine on the phone before placing in the router.
 
These steps are based on helping a few people out who asked for help on my blog:
  1. Log into your TP-LINK router web interface.
  2. Go into the Advanced tab at the top.
  3. If you disabled the SIM PIN using a mobile phone, skip to step 7.
  4. On the left, go into Network -> Pin Management
  5. Tick both 'PIN Lock' and 'Auto-unlock PIN:'
  6. Enter your SIM pin # and click 'Save'.
  7. On the left, go into Network -> Internet
  8. Click 'Create Profile' at the bottom.
  9. Enter the following:
    Profile name: GoMo Internet
    PDP Type: IPv4
    APN Type: Static
    APN: data.mymeteor.ie
    Username & Password: (Leave blank)
    Authentication Type: None
    Click 'OK'
  10. In the Profile Name drop-down, choose "GoMo Internet"
  11. Click 'Save'.
Please note that the APN settings are only for connecting to data.  If the router is having rouble with getting a signal or is not switching to 4G mode, then this is a coverage or interference issue.

If the above settings still do not connect, try following the steps above again, but enter "data.myeirmobile.ie" for the APN field in step 9.
Reply
#2
Go raibh maith agat Sean-Thank you Sean. I tried your solution on an Archer MR200 and Yipeee - Colm
Reply
#3
Has anyone managed to set up a 48 sim correctly to pick up 4g in a TP-Link Archer MR200 router by any chance ? I can't seem to get 4g with it. It has a three APN by default and I've tried setting up another profile using the. 48months.liffeytelecom.com APN but no luck, just picking up 3g. The sim picks up 4g no problem when swapped to a phone, so there's no problem with the coverage.
Reply
#4
When you set the router's network mode to "4G only", does it show a signal reading on the Network Map section? If it does not show any signal, it may either have a faulty modem, the cell could be out of range or possibly Three using band 28 in your area, which the MR200 does not support.

The APN is only used to establish a data connection, so if it does not have a signal reading, then the APN is not the issue. It would be different if it shows a signal percentage, but no Internet access.

If your phone is running Android 7 or newer, you can install the App CellMapper. This will show which 4G band the 48 SIM is using. Check the Timing Advance value. If this is above 20,000m, the cell may be outside the range limit for the router. From my experience trying various routers and phones, LTE Category 4 (or lower) devices have a shorter maximum 4G range limit regardless of the signal strength.
Reply
#5
Thanks for the reply Sean. I tried switching to 4g only on the router, didn't pick up anything, just continues with `connecting` but never connects.

I took a look at the CellMapper app on the phone with the same sim, timing advanced value was always below 10,000m the few times I checked it. I did notice the band in CellMapper though went between 20 to 28 but mostly 28, which might be what the issue is.

Another family member has a 3 sim in a different router (MR6400) in the same house, so I tried that in the MR200 just to see if it would work, and it picked up 4g almost straight away. Which I thought was strange, but could it be that 3 are only using band 28 for their MVNO's ?
Reply
#6
That is interesting as it's been several years since I saw Three restricting MVNOs to certain bands, mainly former O2 3G cells. You are certainly well within range of the mast. From what I can tell on TP-LINK's specs, the only difference between the MR6400 and the MR200 is that the MR200 has 802.11ac (5GHz) Wi-Fi, but otherwise both have the same category 4 modem and same cellular bands (neither support band 28).

Just in case the TP-Link does not show a signal reading without an active data connection, try updating the APN profile to the following. These are based on 48's Android settings, which has 'User' as the username and 'PAP' as the Authentication:

Profile name: 48 Months
PDP Type: IPv4
APN Type: Static
APN: 48months.liffeytelecom.com
Username: User
Password: (Leave blank)
Authentication Type: PAP

In Basic -> Internet, ensure the "48 Months" is selected in the Profile Name drop-down and click 'Save'.
Reply
#7
Hi,
I have an mr200 and a 48 SIM. I'll match your setup in the next hour or so and post results locking to 4g.
Be back soon. ?
Reply
#8
(18/11/2020, 10:19 PM)the_dan Wrote: Has anyone managed to set up a 48 sim correctly to pick up 4g in a TP-Link Archer MR200 router by any chance ? I can't seem to get 4g with it. It has a three APN by default and I've tried setting up another profile using the. 48months.liffeytelecom.com APN but no luck, just picking up 3g. The sim picks up 4g no problem when swapped to a phone, so there's no problem with the coverage.

Hi @the_dan,

So just completed the test here,  MR200 with 48 SIM and APN profile.  Locked on 4G Only.

No issues with attaching and speed tests / browsing.  Make sure you have the correct APN seletced.  You may well have the profile created but just double check that you are using the APN from that created profile.

Maybe check that the MR200 has the latest firmware also.

Best of luck
Reply
#9
I gave it another try tonight with the updated APN, and did manage to pick up 4G. It didn't happen straight away though, I just kept trying a few different things; changing APN's and switching between 4g only and auto. Eventually at one point the 4G light lit up on the router, happy days. At least I know it can be picked up now, just slow to happen and takes a bit of messing around.

I guess it must be down to the location I'm at and different bands used possibly. As I have an Eir sim also, and as soon as I swap back to that its on 4G almost instantly. That's before I even have a chance to change the APN back from 48 to the Eir one.

Thanks a lot for the help @Sean and @Comsman, much appreciated.

The firmware on my MR200 is `1.2.0 0.9.1 v004a.0 Build 170927 Rel.58861n` btw, I've never updated it but it says that's the latest.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)